Rocksolid Light

Welcome to RetroBBS

register  nodelist  faq  

I may not be totally perfect, but parts of me are excellent. -- Ashleigh Brilliant


rocksolid / Helpdesk / latest

Re: clearnetsite not loading

rocksolid.shared.helpdesk

Posted: 5 Days 10 Hours ago by: retro.guy"

Censorship online has gone mainstream over the past few years. The number of people that feel that is the way to win an argument (by shutting down those who disagree) is appalling. If it takes getting voices shut down, people fired from t

Re: Clearnetsite not loading

rocksolid.shared.helpdesk

Posted: 5 Days 21 Hours ago by: Retro Guy"

That's exactly what I was trying to avoid by blocking users by sessions instead of ip addresses, which seems to be working well. Years ago I ran a popular clearnet site and blocked a few ip addresses of pita users and then realized I was

Re: Clearnetsite not loading

rocksolid.shared.helpdesk

Posted: 5 Days 22 Hours ago by: Anonymous"

If this is on purpose, they are not trying but successfully doing it. :-) Could be though that they just do IP based rate limiting, in which case a dos attack coming from one exit node would prevent you to access reddit from the same exit

Re: Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 5 Days 23 Hours ago by: Anonymous"

I get the same. Maybe reddit is trying to block tor users?

Re: Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 6 Days ago by: Anonymous"

It gives 503s when the access is done via tor (still today). That could be part of an ongoing ddos and/or the resulting counter measures. I could access the site just fine without tor. meeh...I hate it when clearnet sites cannot be visite

Re: Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 6 Days 11 Hours ago by: Anonymous"

I haven't noticed that. It's working for me. I think ddos can cause a 503 by overloading the server, but it's working now and was yesterday anyway.

Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 6 Days 22 Hours ago by: Anonymous"

since yesterday, I only get 503s. is reddit under attack as well ?

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 7 Days 12 Hours ago by: Anonymous"

Kind of makes me glad I've waited moving to v3: https://www.reddit.com/r/TOR/comments/kunv6n/v3_onion_workaround/

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 7 Days 14 Hours ago by: Anonymous"

seems like the tor people are trying to solve it already: https://gitlab.torproject.org/tpo/core/tor/-/issues/40237 https://darknetdaily.com/?p94

None

rocksolid.shared.helpdesk

Posted: 8 Days 17 Hours ago by: Anonymous"

Facts or links, please.

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 8 Days 19 Hours ago by: Guest"

Coup in progress USA. v3 Tor not woking. Major attack on some i2p routers too. -- Posted on def3

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 9 Days ago by: Anonymous"

The tor network is under attack currently, it started around 2 days ago, see one of the threads on tor (http://def2.i2p/to/res/431.html).

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 9 Days 2 Hours ago by: Anonymous"

Have you looked at the web server logs? Did you change any settings, like what interface the web server is bound to? I assume when you went onto your "site on another machine", that means not through tor. So if your site is only respondi

Onion site not loading

rocksolid.shared.helpdesk

Posted: 9 Days 10 Hours ago by: Anonymous"

I was working on a personal onion site that uses Php, and everything was fine until about two days ago. My personal onion site suddenly isn't loading up on Tor. It says "The connection has timed out The server at (mysite).onion is taking t

Re: Fonts in tor browser

rocksolid.shared.helpdesk

Posted: 17 Days 22 Hours ago by: Anonymous"

The tor browser can load fonts, you can test it here on def4 for example: http://acmsrfsbsogtuhvk.onion/bbx/ Could it be that the url needs to be expressed differently ? You do: src: url('MyFont.eot'); Maybe it must be: src: url('/fon

Fonts in tor browser

rocksolid.shared.helpdesk

Posted: 18 Days 9 Hours ago by: Anonymous"

I downloaded an external font and I'm using it for my webpage. My code is this: @font-face{ font-family: "MyFont"; src: url('MyFont.eot'); src: url('MyFont.eot?#iefix') format('embedded-opentype'), url('MyFont.woff2') format('w

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 21 Days 1 Hour ago by: Neodome Admin"

If you will ever need it in the future, INN allows to use IHAVE on per-user basis. You don’t have to turn it on for everyone.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 22 Days 21 Hours ago by: trw"

Thanks Neodome, for the explanation, it is pretty clear to me. And yes, it is understandable that it is not used if it enables the kind of forgery you describe. Luckily, with the use of rpost, I don't need it.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 23 Days 9 Hours ago by: Neodome Admin"

It probably was kept for backwards compatibility with software that was in use back in old days. As far as I know, none of the major newsreaders support IHAVE. Articles sent using IHAVE should contain all required headers, including Date

Re: uudecode driving me nuts

rocksolid.shared.helpdesk

Posted: 28 Days 11 Hours ago by: trw"

def4 is NOW displaying embedded attachments (like def3 generates them) damn it

Re: uudecode driving me nuts

rocksolid.shared.helpdesk

Posted: 28 Days 11 Hours ago by: trw"

10 s after I posted I realized that the file to decode was not named correctly....thanks for all your help :-] def4 is not displaying embedded attachments (like def3 generates them)

uudecode driving me nuts

rocksolid.shared.helpdesk

Posted: 28 Days 12 Hours ago by: trw"

To decode attachments which are embedded in the body of an article I tried to make use of uudecode. On the cli this command works nicely: uudecode -o /var/www/bbx/att/image.jpg /var/opt/msg/18329@test.com It produces a correct file by the

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 28 Days 23 Hours ago by: Retro Guy"

rpost is nice. It's made repetitive things easy for me (nocem, chkgroups messages, etc.)

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 28 Days 23 Hours ago by: trw"

Yes, when doing POST the server suggests a message-id, but does not insist on it, you can still announce your own. Basically, rpost solved all the issues around posting for me.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 29 Days 1 Hour ago by: Retro Guy"

If your prog requires the server to allow IHAVE, you limit yourself to what servers you can connect to. Many (most?) won't allow it. Also rslight server doesn't even support it. I think you already posted that you found you can set the m

Re: Bracket Match Not Found

rocksolid.shared.helpdesk

Posted: 29 Days 1 Hour ago by: retro.guy"

The brackets look ok in my editor (vi). This is assuming that it's all one line, not broken into two lines. When you run it, what get's echoed, text 1, 2 or 3? While you're testing, echo all sorts of stuff (and delete it later). Like va

Re: Bracket Match Not Found

rocksolid.shared.helpdesk

Posted: 29 Days 2 Hours ago by: trw"

While i agree that some stuff should not be shared, the problem I see with your approach (of changing the code for publishing) is that you/we will not catch any typos in the code, only wrong constructions or something like that. For me, t

Bracket Match Not Found

rocksolid.shared.helpdesk

Posted: 29 Days 8 Hours ago by: Anonymous"

`user_name`, `password`) #####VALUES('', '".$user_name."', '".$password."')";##### if(mysqli_query($con, $q)){ echo '{text1}' ; }else{ echo "{text2}" ; } }else{ echo "{text3}" ; } } ?>

Re: Posting an article with telnet - solved

rocksolid.shared.helpdesk

Posted: 29 Days 16 Hours ago by: trw"

Ok, in the script it was necessary to filter out the leading tabs, done with

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 29 Days 17 Hours ago by: trw"

Closing connection to 192.168.1.1 The same put in a function of my script: Output: Using Port 4567 Official host name: 192.168.1.1 Connected to 192.168.1.1 200 rocksolid2 InterNetNews NNRP server INN 2.6.1 ready (no posting) Attempting

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 29 Days 22 Hours ago by: trw"

and one more question in relation to posting: would it be a problem to enable IHAVE on an inn2 ? the advantage would be that the message-id could be predefined as thus known to the code. or maybe i could achieve the same with POST ?

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 29 Days 22 Hours ago by: trw"

The script is garbled up of course. I can upload it somewhere if someone wants it.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 29 Days 23 Hours ago by: trw"

yes, rpost was discussed before, see here: http://x5qrtsbiebrxj65t.onion/index.php?t=msg&goto204 i still don't have it on my server (running debian buster), but now i realize it is a part of suck, so i will give it a try. the target of

33 recent articles found.

rocksolid light 0.6.7
clearnet i2p tor